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Ml

UCINET Basics

o Official User's Guide of UCINET

— http://www.analvytictech.com/Ucinet Guide.doc

o Official UCINET Tutorial

— http://faculty.ucr.edu/~hanneman/nettext/

* Help in UCINET
— Help > Help Topics

» Contents: Introduction Section, DL, and Standard Datasets.

* Index: search by keywords.
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Ml

The UCINET Environment (l)

« Main window

— File, Data, Transform, Tools, Network,
Options, and Help.

UCINET; 6 for Windows -- Version 6.109.

Fls Data Transform Tools Network Draw Options Help

[I=RNDE e
Hom to cte UCINET.
Borgati, 5.F., Everet, M.G. and Freeman, L., 2002 Uciet for Windoms: Software for Sacial Network Analsis. Harvard, Mé: Anallic Technolagies.

|4 UCINET tutorial by Bob Hanneman is avallable ot htp:/faculty. ucredu/hanneman/neftext/
Succasshly opened input flle

Read header infomation.

Read data

Did clean-up.

‘w/iote data to disk.

Read data.

Did clean-up.

Wiole datato disk,

Files\Ucinet Bydatafiles] -l
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Mid
The UCINET Environment (ll)

« The UCINET dataset

— One dataset consists of Two files.

— File with extension ##D: actual data.

— File with ext. ##H: information about the data.
— In referring to a dataset, refer to the .##H file.
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Ml

The UCINET Environment (lil)

* A typical UCINET procedure

Input Parameters — — Output Text
Procedure
Input Datasets — — Output Datasets
* Qutput text in Log Files
— File>View Previous Output...
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= Mid&q
A Quick Demo

. Dataset: KNOKBUR (.##H & .##D)

* 10 organizations and two relationships.
— Directed graph.

— Money exchange in one matrix, and
information exchange in the other.

— See Knoke & Kuklinski (1982) for details.
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0= UCINET 6 for, Windows -- ¥ersion 6.109

ndow: Data>Display...

File Transform  Tools  Mebwork
[l Spreadshests
Howw Random
Borg: Impork
Expork
A LG Atktribute ...
| Affiliations ...
C55 ...
Browse
Describe Crrl+B
Extrack ... Chrl-

Exktract rmain component
Subagraphs From partitions
Remove isolates

Rermove pendants
Egonet

Unpack. ...

Jdain ...

Permute ...
Sort ...
Transpose ... Chrl+T

Partitions ko Sets. ..
Create Node Sets ...
Reshape ...

C\Program FilesiUcinet 6\Data

Draw Options  Help
L4

*

002, Usinet far Wwindows: Saftware for Social Metwork Analpsiz. Harvard, A Analptic Technologies

at http: Affaculty. ucr edus~hannemannettext/

Ral=
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Data Set Filename:
KNOKBUR . .##H

lﬁ'] UCIMET 6 for Windows -- Version 6.109

Fil= Data Transformm  Tools  Mebwork Drawe  Options  Help

— ~m
E ~, D Xhedangs
Hows bo cite LICINET:
Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettext/

Display Datasets

Data Set Filename: I;s\Ucinel 6iD ataFilesA\KNOKBUR _##H ...I

width of fields: IMIN x Cancel |

# of decimals:
[MIN ? Hep

Print zeros as: I|]

Scale factor: |1

Wwhich rows: Ia“ _I LI
Wwhich columns: Ia“ _I LI

~3

C:\F'ro gram FilesiUcinet 6\DataFiles
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% Qutput Log #1

Output log #1

Fil=  Edit

& | 50| Br| oh| 8|

DISPLAY

Width of field:

# of decimals:

Row=s to displaw:
Column=s to display:
Fow partition:
Column partition:
Input data=set:

Matrixz #1: EHOKI

RrOROORRORO| QR
RPHRHEPORRPROR| O
l=1=1=11 === N, [
COHRHORORREO | His
HHEHRHEOOHEERE| 20
oooooooroo | Ho
RPHHEORRRRRER| 5

D0 =] T U LRI

i

coooorRooRo| Do

CORORROORK| W

oooooOroOHrOD | SO

MIHN
MIHN
all
all

C:~wFProgram Files“Ucinet &~DataFiles~KHOKEUER

H
8]
=
=
o]
L
=

Matri=x

O D 0~ T O e L R P
ocooooooooo | H
coorRaORROoo | M
COROOORHORRE | Tw
CoOo0o0000o000 | His
ocooooooooH | a0
cooooooooo | 2o
ocoooooRoOOoO | E.

[

CORORORRREOR | Do

CoOROORROOR | W

CoOHrOOOOOOH | SOF

3

£
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Main window: Draw
File>Open>Ucinet dataset>Network

EZ] NetDraw 2.29 - Metwork Visualization Software

HIEN Layouk  Properkies  Analysis  Transform  Options  Help

i blank, ~ i =1 =
,:,II_ ank) __ it ._--- failiie r: Dl"h..lnl: LF o7 = Ise Pes MC| Ego ~Del EE YID. Pélirl}ﬂ 1o s Z’T o il -

Random

2-Mode etwork Fielz INDdBSI Ties ]

Helations:
Atktribute data

Pajek text File

i »
Save Diagram s vha text file

Sawve Data As » Coordinates
Edit »
Prinkt

Default Folder

Batch
Exit

on| up| o | ] & |

> =|[o s
Options:
" AMD  Link wts [

i« OR Inc: |1

[ "width [ Caolor

Engineering Systems Division
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Name of file to open: KNOKBUR.##H

EZ] NetDraw 2.29 - Metwork Visualization Software

Fil= Layout Properkies Analysis Transform  Options  Help

b = =s & LF 3% G PC MDS & % -1ise Pen MC|Ego ~Del ZB

=1 4 Kim

|

Rill

6 =5 =f L[ e

F=Z] Open Data File

M ame of file to open:

IC: “Program FilezsUcinet BAD ataFiles"\KNOKEBUR #H#H

Fil= format:
= Ucinet [* ##h = f#Hd]
i WA [Fwnal

DL [=.dl

i Pajek Network [%. net]
i Pajek Partition [*.clu)
i Pajek Yector [F.vec]

Type of Data:

= 1-Mode Hetwork[=]
 Mode Attributel=z)

€ Metwark with Sttributes
& Z-Mode Metwark,

" Mode Coordinates

Rels INDdBSI Ties I
Helations:

on| up| o | & B |

Options—
i AMND  Link wis [

= 0OR Inc: I‘I

I width [ Color

[ B o
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EZ] MetDraw 2.29 - C:\Program Files\Wcinet 6\DataFiles\KNOKBLIR. ##h &

File Layout Properkies Analysis Transform  Options  Help

D o ocws & X3 O B LY G PC MDS - ise Pea MC|Ego ~Del

ool HE L[ aal.

Rels INDdBSI Ties ]
Helations:

| KMNOKI]
EMOK M

> €3 iTunes [ cal Guides - M...

on| up| o | ] & |

- - | Size:

> =0 |
Options:

" AMD  Link wts [
i« OR Inc: |1

[ "width [ Caolor

49 ties.

| N e
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Main window:
Network>Centrality>Degree...

0= UCINET 6 for, Windows -- ¥ersion 6.109

File Data Transform  Tools Draw Options  Help
o | i »
1 ~, D XleX%a cohesion ’
Haw to cite LICINET: =
Subgroups 3
Borgatti, 5 P Ewverett, M. G, and | ar Social Metwark Analysiz. Harvard, A Analptic Technolagies

Ego Mebworks

A UCIMET tutarial by Bob Hanner -
I Eigenwvector ...

»
»
Group Centrality 3
»
»

CarefPeriphiery Pawer ...

Raoles 2 Positions Influence ...

F1... Closeness

Compare densities » Reach centrality
Compare aggregake proximiky matrices ... # Information ...

2-Mode 3 Betweenness 3

Flows Betweenness ...
Fragmentation

Multiple Measures ...

c:\Program Files\Ucinet B\datafiles j =]
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CIMET 6 for Windows -- Version 6.109
Mebwork Draw  Options  Help

File Data Transform  Tools

Input dataset: KNOKBUR.##H

— ~m
E ~, D Xhedangs
Hows bo cite LICINET:
Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettext/

Degree
Input dataset: [\Ucinet G\DataFiles\KNOKBUR ___ | « Ok

Treat data as symmetric: I'fes vI x Canceal I

Include diagonal values? [ygo -
I _I | “? Help I

Output dataset: IFreemanDeglee

~3

c:'\F'ro gram Files\Ucinet G\datafiles
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Output log #2

7 Output Log #1

Edit
_EI E-;!;_I_EJ Log File Mumber 1

FREEMAN'S DEGREE CENTRALITY MEASURES

Diagonal walid?
Model:
Input datas=et:

R=lation 1: EKEHOKI

HO
ASYMHETRIC

Z o wFrogram Files~Ucinet 6~DataFiles~KHOKEUE

1 2 3 4
DutDegres InDegres= HrmOutDeg HrmInDeg
1 4000 S.000 44 444 55.556
2 7.o00o0 2.000 77778 8288 .889
3 &.000 4.000 6 .EET 44 444
4 4. .000 S5.000 44 444 55.556
5 8.000 g.000 88 .889 828.889
=] 23.000 1.000 33.333 ki B B
7 3.000 9.000 33.333 i00.000
=] 5.000 2.000 GG .E6T 22.222
a 3.000 S.000 F3393 55.556
i0 S.o000 2.000 55 .EE8 22.222
DESCRIPTIVE STATISTICS
1 4
CutDegree InDegre= HrmOutDeg HrmInDeg
a5 Hean 4. .900 4.900 S4.444 S54.444
2 5Std Dew 1.700 2.62 1a.889 29 165
] Sum 49 000 49 000 44 444 544 444
4 Variasnce 2.890 6,890 356 .790 850.617
5 S50 269 .000 309 .000 33209 .875 38145 .148
=] HCS50 28.900 58 .900 3567 .901 8506.173
7 Euc Horm 16 . 401 17.578 182.226 195 .316
8 HMinimum 3.000 1.000 332.333 11.111
9 HMamimum g8.000 S.000 g8 .889 100.000
Hetwork Centralization (Outdegres) = 38 272X
Hetwork Centralization (Indegre=) = 50.617X
Eelation 2: EKHOEHM
1 2 3 4
DutDegres InDegres= HrmOutDeg HrmInDeg

>

€
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Main window:
File>View Previous Output...

CINET & for Windows -- Version 6.109

Daka  Transform  Tools  Mebwork Drawe  ©ptions  Help
Change Default Folder ... Ctrl+F
Creakte Mew Folder ...
—opy UCII‘IEF e L.C. 2002 Ucinet for Windows: Saftware for Social Netwaork &nalpzis. Harvard, BMa&: Analptic Technologies
Rename Ucinet Dataset
Delete Ucinet Dataset silable at http: Affaculty. ucr edus~hannemandnettext/
Print Setup ...
Texk Editor ... Ctrl+E
CErl4+0
Launch Mage
Launch Pajek.
Exit Al
c:\Program Files\Ucinet B\datafiles | =

I T Engineering Systems Division
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Main window:

Data>Spreadsheets>Matrix

= LUCINET 6 for, Windows -- Yersion 6

109

Transform  Tools  Mebwork. Draw  Options Help

Howw Random [
Impork
Expork
A LG Atktribute ...
| Affiliations ...
C55 ...

Browse
Display ... Ckrl4-D
Describe Ckrl+B

Extrack ... Chrl-
Exktract rmain component
Subagraphs From partitions
Remove isolates

Rermove pendants

Egonet

Unpack. ...

Jdain ...

Permute ...
Sort ...
Transpose ... Chrl+T

Partitions ko Sets. ..
Create Node Sets ...
Reshape ...

002, Usinet far Wwindows: Saftware for Social Metwork Analpsiz. Harvard, A Analptic Technologies

at http: Affaculty. ucr edus~hannemannettext/

|C:\Program FilesiUcinet B\DataFiles

Ral=
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UCINET Spreadsheet:
File>Open>FreemanDegree.##h

CINET 6 for Windows -- Version 6.109

Fil= Data Transformm  Tools  Mebwork Drawe  Options  Help
— -~ m
E ~, D Xhedangs
Hows bo cite LICINET:
Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies
A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettext/
% UCIMET Spreadsheet - untitled
@E8 Edit  Transform  Fill Labels ©Options Help

MSw Fil | +0| -0|Re

Sawve Chrl+5 I I I I I I -~ —Current cell:

Save As Fow: Cal:

Close ID— ID—

Prinkt ...

Printer setup - Dimenzions

Close Fows:  Cols

L8 ISD lSD
T Mode——
' Mormal
" Syrmretric
et
< I | )
Fage 1 I |
I I Z
—

IC:\Program FilesiUcinet B\DataFiles vl =

€2 iTunes il Guides - Micro. .. 3 htt ik, . [EE UCIMNET Tutorial =] Ucinet & For

I T Engineering Systems Division
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HEE]

OutDeq... [InDegree  [MrmOut... [MrminDeg | Current cell:

1 4 5 44 44444 55 55555 Fowe  Cok
27490234 | 72509766 0 [

2 | 7 G 7777777 0B.888S0 2 =)
- BE2548083 | 54050469
3 [5 4| G6.GEGEE | 44 44444 Dimensions
. 41235352 27490234 Fows: Caols:
4 4 5 44.44444 5555555 [0 &
- 27490234 | 72509766
5 8 G | 65.86883 | 85.58855
- 54980468 54980469 Llede
5 3 13333333 11.11111 o eyl
- 20617676 ORG72550 " Symmetric
7 3 o 33.33333 100
- 20617676
=] [ 2 | 66.66666 | 2222222
- 41235352 [ 13745117
=] 3 5| 33.33333 | 55.55555
- 20617676 | 72509766

72509766 13745117

1 5 2| 55.55555 | 2222227

KMOEI | KMOKRM

I T Engineering Systems Division
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Ml

Import Data

UCINET spreadsheet

— Adjacency matrix
— Manually input data or cut and paste from elsewhere

From Excel file
DL format

— Full matrix & rectangular matrix
— Multiple matrices

— nodelist1 & nodelist2

— ranklist1

— edgelist1 & edgelist2

More information about DL language
— Main window: Help>Help Topics>Contents>DL

] » Engineering Systems Division
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UCINET spreadsheet

Data>Spreadsheets>Matrix

INET 6 for Windows

Transform  Tools

Random [
Impork

Expork

Atktribute ...

Affiliations ...

C55 ...

Browse
Display ...
Describe

Crri+-D
Crrl+B

Extrack ... Chrl-
Exktract rmain component
Subagraphs From partitions
Remove isolates

Rermove pendants

Egonet

Unpack. ...

Jdain ...

Permute ...
Sort ...

Transpose ... Chrl+T

Partitions ko Sets. ..
Create Node Sets ...
Reshape ...

Mebwork Draw  Op

002, Usinet far Wwindows: Saftware for Social Metwork Analpsiz. Harvard, A Analptic Technologies

at http: Affaculty. ucr edus~hannemannettext/

c:\Program Files\Ucinet B\datafiles

~|
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lﬁ'] UCIMET 6 for Windows -- Version 6.109

Mida

anually Input Adjacency Matrix

Fil= Data Transformm  Tools  Mebwork Drawe  Options  Help

0 m@EN D Osis

Hows bo cite LICINET:

=] UCINET Spreadsheet - untitled
File Edit Transformm Fill Labels ©ptions Help

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettext/

Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

A

Current cell:
Row:  Caol

ol o

Dimensions

Thode————
& Mormal
 Swmmetric

F'a;:.;e il I

c:'\F'ro gram Files\Ucinet G\datafiles

~3
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icrosoft Excel - KNOKBLIR_Example

Mlda

mport Adjacency Matrix from an Excel File

wRE REE R

D EdHS®m SE Y| 4B =

A1 - Fe KMNOKR

Arial

fEAD  FEFHE TROD EEDy \ED SRR

@ > -2z W B 100%

- 8 - | B

A | B [ © | ] | E

F

KPR ZOUR 0N EDILIC IMDU
1

o
oo

000~ 3| e L) b=

oo~ m AWk

ooooooo0o0oo0o
QoOQ|=|0|=|=(0(Q|0
Q=QQ|Q|=(=(Q|=>
oooo o000

=5
s,
Y
o

|
3@’— -

[

OoD0O|0|0|0OjO(O(O|=

VR

=
DDDDDD—‘DDD%I

o g e e T o o o o o
=3 (=N (=1 Y Y Y (= Y

O0=|0|0|=|=(0(0O|=
Qo=|Q|0|0O0(Q|=

o4k M [ KROKD s KNOKM

it /7

N

| _LIJZI

NTThA

>

e am = =
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Transform  Tools  Mebwork. Draw  Options Help

[l Spreadshests 3

Howw Random L2
oL Certex

Borgs X y

Expork * Mulkiple DL Files
A LG Atktribute ... WA nemandnethext!

affiliations ... Paijek.

£S5 ... Krackplat ...

Megopy ...

ware for Social Metwaork. &nalpzis. Harvard, M Analptic Technologies

Browse
Display ... Ckrl4-D
Describe Ckrl+B

Fave ...

Extrack ... Chrl-
Exktract rmain component
Subagraphs From partitions
Remove isolates

Rermove pendants

Egonet

Unpack. ...

Jdain ...

Permute ...
Sort ...
Transpose ... Chrl+T

Partitions ko Sets. ..
Create Node Sets ...
Reshape ...

|C:\Program FilesiUcinet B\DataFiles j =

I T Engineering Systems Division
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_

JIE xcel file to import: KNOKBUR_Example.xls
Output dataset: KNOKBUR_Example

B2 D e ias

Hows bo cite LICINET:
Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettext/

Import Adjacency Matrix from Excel

File names:

Excel file to import: Program Files\Ucinet B\DataFilesh"KHNOKBUR_Example_ xls ___

Dutput dataset: |C:3Program Files\Ucinet 6\D ataFiles\KNOKBUR_Example X Cancel

“‘? Help

Dimensions and Labels Format of data in Excel file:

[v FRow labels present i~ Mode attribute matrix
[v Column labels present + MNetwork adjacency matrix

I« Relation labels present

c:\Program Files\Ucinet B\datafiles LJ =

I T Engineering Systems Division
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Ml

DL Format: Full Matrix

 Full Matrix Format

dl n=4 format=fullmatrix
data:

0110

1011

1100

0100

« Save it as a text file (e.g. TEST.txt).

Engineering Systems Division
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File Transform  Tools  Mebwork. Draw  Options Help
[l Spreadshests 3
Howw Random L2

Expork * Mulkiple DL Files

A L Attribute .. WS,

| affiliations ... Paijek.
£S5 ... Krackplat ...

Megopy ...
Browse
R Raw ...

Display ... Ckrl4-D
Describe Crrl+B Excel matrix
Extrack ... Chrl-

Exktract rmain component
Subagraphs From partitions
Remove isolates

Rermove pendants
Egonet

Unpack. ...

Jdain ...

Permute ...
Sort ...
Transpose ... Chrl+T

Partitions ko Sets. ..
Create Node Sets ...
Reshape ...

ware for Social Metwaork. &nalpzis. Harvard, M Analptic Technologies

nemandnethext!

|C:\Program FilesiUcinet B\DataFiles

Ral=

| N e
I I I I I Massachusetts Institute of Technology
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Mid
Format: Rectangular Matrices

dinr=6,nc=4
data:

0110

1011

1100

0100

1011

1100

Engineering Systems Division

| B
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Mida
DL Format: Labels

* DL file may contain labels of the nodes

dl n=4

labels:

MIT, “MIT ESD”, MIT.ESD.342, ESD Students
data:

0110

1011

1100

0100

] T Engineering Systems Division
I I" Massachusetts Institute of Technology Mo-Han Hsieh



Mid
DL Format: Multiple Matrices

dn=4,nm=2

labels:
GroupA,GroupB,GroupC,GroupD
matrix labels:

Marriage,Business

data:

0101

1000

0010

1001
!

_ O
© OO -~

1
0
0
1

O -~0 -

] T Engineering Systems Division
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b iy Mida
DL Format: External Data

e Data file can be read from other sources

dln=328

labels:

al,a2,a3,a4,a5,a6,a7,ad

datafile C:\DATA\External Data.DAT

I T Engineering Systems Division
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Mids
DL Format: nodelist1 (l)

dl n = 4, format = nodelist1

labels:

A,B,C,D

data: _ _

123 Resulting Matrix =>

2 134 A |B |C|D

312 A0 1 [1]0

4 2 B (1|0 [1 |1
Cl|1 1|1 ]0 |0
D (0 [1 |0 |O

] T Engineering Systems Division
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Mids
DL Format: nodelist1 (ll)

dl n = 4, format = nodelist1
labels:

A,B,C,D

data:

123 A
213
2 4
312
4 2

Resulting Matrix =>

OO0 | >
o|l-|~|O
~lalola]m
olo|l=|=0
olo|=~|lo|lg

] T Engineering Systems Division
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Mids
DL Format: nodelist1 (lll)

dl n = 4, format = nodelist1

labels embedded

data:

A BC Resulting Matrix =>

B ACD A |B |C |D

CAB Al10 1 1110

DB B |1 |0 |1 |1
Cl|1 |1 (0|0
DO |1 |0 |0

Engineering Systems Division

| B
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DL Format: nodelist2

Ml

dl nr=3, nc=4 format = nodelist2
row labels embedded
column labels embedded

data: Resulting Matrix =>
GP1 A B A B C D
GP2 CD GP1 |1 1 0 0
GP3 AD GP2 |0 0 1 1
GP3 |1 0 0 1

[ N
II I “ Massachusetts Institute of Technology

Engineering Systems Division

Mo-Han Hsieh



Mida
DL Format: ranklist1

dl n=4 format = ranklist1

labels embedded

data:

A BC

B CDA Resulting Matrix => A B IC ID

C ABD A0 112 1|0

D AC B (3 [0 |1 |2
Cl|11]2 |0 |3
D1 |0 |2 |0

] T Engineering Systems Division
I I" Massachusetts Institute of Technology Mo-Han Hsieh



Midz
DL Format: edgelist1

dl n=4 format = edgelist1

labels:

A,B.CD

data:

1 2 1

1 32 ) .

51 1 Resulting Matrix => A B IC ID
2 3 1 A1l0 (1 |2 |0
5411 1 B (1 (0 |1 |1
3 2 na C |1 0 |0
4 252 D |0 |>2]0 |0

] T Engineering Systems Division
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Ml

DL Format: edgelist2

dl nr=3 nc=5, format = edgelist2

labels embedded:

data:

A1 B1 1

A1 B2 1.5 Resulting Matrix =>

A1 B3 2 B1 |B2 |B3 |B4 |B5
A2 B1 1 A1 [15]2 o o
A3 B2 3 A2 11 [0 |0 [0 |oO
A3 B4 2 A3 |0 |3 |0 |2 |1
A3 B5 1

] T Engineering Systems Division
I I" Massachusetts Institute of Technology Mo-Han Hsieh



MIda
Export Data

« Export UCINET dataset to

— Excel file
* Number of columns < 257

— DL format

« Easy to do cut and paste
« Example: Cut and paste as a Matlab data file.

— Other format

] » Engineering Systems Division
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Export Dataset
Data>Export>DL...

0= UCINET 6 for, Windows -- ¥ersion 6.109

File Transform  Tools
[l Spreadshests
Howw Random
Borgs
A LG Atktribute ...
g‘;ﬂ;ﬁ affilations ...
Beac C55 ...
Cid
- Browse
Reac Display ... Ckrl4-D
Did = Describe Ckrl+B
Aok
| Extract ... Chrl+i
Exktract rmain component
Subagraphs From partitions
Remove isolates
Rermove pendants
Egonet
Unpack. ...
Jdain ...
Permute ...
Sort ...
Transpose ... Chrl+T

Partitions ko Sets. ..
Create Node Sets ...
Reshape ...

Mebwork  Draw  Options

»

*
*

c:\Program Files\Ucinet B\datafiles

Help

oL ...
Krackplak ...
Mage

FPajek »
Metis

Fave ...

St tows: Softveare for Sacial Metwork Analypzis. Harvard, kA Analptic Technologies

edus/~hannemandnettext,

Excel ...

Ral=

| N e
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= Mid
Data Processing

* Most of the data processing functions are
in Dataland Transformsubmenus.

« Some useful functions
— Data>Affiliations...
— Data>Extract...
— Data>Remove isolates
— Data>Join...
— Data>Permute...
— Data>Transpose...

] T Engineering Systems Division
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Data Processing
Data>Affiliations...

0= UCINET 6 for, Windows -- ¥ersion 6.109

File Transform  Tools
[l Spreadshests 3
Howw Random L2
Borg: Impork

Expork
A LG Aktribute ...

£S5 ...

Browse
Display ...
Describe

Crri+-D
Crrl+B

Extrack ... Chrl-
Exktract rmain component
Subagraphs From partitions
Remove isolates

Rermove pendants

Egonet

Unpack. ...

Jdain ...

Permute ...
Sort ...

Transpose ... Chrl+T

Partitions ko Sets. ..
Create Node Sets ...
Reshape ...

Mebwork Draw  Options  Help

002, Usinet far Wwindows: Saftware for Social Metwork Analpsiz. Harvard, A Analptic Technologies

at http: Affaculty. ucr edus~hannemannettext/

c:\Program Files\Ucinet B\datafiles

Ral=

| N e
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MId&a
sonvert 2-mode data to 1-mode

CINET 6 for Windows -- Version 6.109

Fil= Data Transformm  Tools  Mebwork Drawe  Options  Help

0 m@EN D Osis

Hows bo cite LICINET:

Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettest/
Successfullp opened input file.

Fiead header information.

Fead data.

Did clean-up.

“wirobe data bo dizk.

Fead data.

Did clean-up.

“wfroke data to disk.

Affiliations [conwvert 2-mode data to 1-mode)

Input dataset: I

Which mode: Innw

Method: iCross—Ploducls [co-occurrence]

Hormalization: lNone

Dutput dataset: !Afﬁliations

c:'\F'ro gram Files\Ucinet G\datafiles l! =

I T Engineering Systems Division
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Data Processing
Data>Extract...

CIMET 6 for Windows -- Version 6.109

Daka  Transform  Tools  Mebwork. Drawve  ©ptions  Help

Fil=

— ~m
E ~, D Xhedangs
Hows bo cite LICINET:
Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettest/

Successfullp opened input file.
Fiead header information.
Fead data.

Did clean-up.

“wirobe data bo dizk.

Fead data.

Did clean-up.

“wfroke data to disk.

Extract SubMatrix

Input dataset: I

Keep or Delete: IKeep

Wwhich rows: IﬁlLL ;I_LI
Which columns: I-l"-'lLL ;I _LI
Wwhich matrices: IALL ;I_LI

Dutput dataset: IExtlact B I

~3

c:'\F'ro gram Files\Ucinet G\datafiles

Engineering Systems Division
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Data Processing

Data>Remove isolates

= [Daka  Transform  Tools  Mebwork  Drawse

B2 D e ias

Hows bo cite LICINET:

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettest/
Successfullp opened input file.

Fiead header information.

Fead data.

Did clean-up.

“wirobe data bo dizk.

Fead data.

Did clean-up.

“wfroke data to disk.

=] Remove Isolates

Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

Input network dataset: il

Dutput network: IN alzalates

0

c:'\F'ro gram Files\Ucinet G\datafiles

~3
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Data Processing
Data>Join...

CINET 6 for Windows -- Version 6.109

Fil= Data Transformm  Tools  Mebwork Drawe  Options  Help

0 m@EN D Osis

Hows bo cite LICINET:
Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettest/
Successfullp opened input file.
Fiead header information.
Fead data.

Did clean-up.

“wirobe data bo dizk.

Fead data.

Did clean-up.

“wfroke data to disk.

IIEI c: [hp_pavilion] _v] = o -~

==+ Program Files

=

£ Asttribut

Possible Files: Files selected:

almoincidence. #ih
BEFRaT . #H#H
BEHAM. HHH =
BEOFF.HH#H

BETEC.##H

borgdcent. Hith B33
Carmp32 #ih
campattr2 H#h
campnhet. Hith
cartervear! . ##th
carteryeard. Hih
CITIES. ##H <
Clustert etrics. Hih

Components Partition kb | ¥

[+

Sl EELE

" Columns

i Matrices

Destination filename:
I.Joined

c:'\F'ro gram Files\Ucinet G\datafiles
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Data Processing

Data>Permute...

CIMET 6 for Windows -- Version 6.109

Fil= Data Transformm  Tools  Mebwork Drawe  Options  Help

0 m@EN D Osis

Hows bo cite LICINET:

Successfullp opened input file.
Fiead header information.
Fead data.

Did clean-up.

“wirobe data bo dizk.

Fead data.

Did clean-up.

“wfroke data to disk.

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettest/

Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

New order of cols:
MNew order of matrices:

Output Filename:

FPermuted

Permute |'£|
Input dataset: I __I f oK
New order of rows: 2 Cancel I
‘? Help

c:'\F'ro gram Files\Ucinet G\datafiles

~3
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Data Processing
Data>Transpose...

CIMET 6 for Windows -- Version 6.109

Daka  Transform  Tools  Mebwork. Drawve  ©ptions  Help

Fil=

— ~m
E ~, D Xhedangs
Hows bo cite LICINET:
Borgatti, 5 F. . Ewverett, MG, and Freeman, L. C. 2002 Ucinet for Windows: Saftmare for Social Netwaork &inalyzis. Harvard, BMA&: Analptic Technologies

A UCIMET tutarial by Bob Hanneman iz available at http: Affaculty. ucr edus~hannemandnettest/

Successfullp opened input file.
Fiead header information.
Fead data.

Did clean-up.

“wirobe data bo dizk.

Fead data.

Did clean-up.

“wfroke data to disk.

Transpose

Input dataset: I __J —
___i x LCancel I

Dutput dataset: I—T

~3

c:'\F'ro gram Files\Ucinet G\datafiles
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0= UCINET 6 for, Windows -- ¥ersion 6.109

File Data

Howw to cite |
Borgatti, 5 F

A UCINET by
Successfully
Fead heade
Fead data.

Did clean-up
“wroke data b
Fead data.

Did clean-up
Aok data b

Tools Mebwork Draw  Options  Help

Elock ...
Collapse ...

Dichokomize ...
Symmekrize ...,
Mormalize ...
Match Marginals
Recode ...
Reverse ...
Diagonal ...
Double

Fewire

Matrix Operakions

Union
Bipartite ...
Incidence ...
Linegraph ...
Multigraph ...
Multiplex ...
Semigroup ...

Chrl+alk+k
Crrl+alk+C

Cerl+Alk+D
Crrl+alk+3
Crrl+-alk+rM

Crrl+alk+R
Crrl+alk+y
Crrl+alk+G

Chrl+alk+B
Crrl+-alk+I
Crrl4+-alk+L
Cerl+-alk+r
Crrl+alk+x
Crrl+alk+P

Uecinet far wWindows: Saftware far Social Metwaork Analpsiz. Harvard, kA Analptic Technologies

itkp: Affaculty. ucr edu/~hannemandnettest

c:\Program Files\Ucinet B\datafiles

Ral=

Engineering Systems Division
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b Midz
Tips of Using UCINET

« Before using an UCINET function
— Check it out in Help>Help Topics>Index

— Purpose, Description, Parameters, Log File, Timing, Comments,
and References.

— Timing is sometimes important

* Function with O(N”*3) can be a problem for networks with
more than 1,000 nodes.

« Setup the following two directories before start
working with the UCINET

— File>Change Default Folder...
— Options>Output folder

] » Engineering Systems Division
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